PreviousNextTracker indexSee it online !

(79/231) 2865735 - Mouse pointer displaced a few pixels

I run jedit on a linux server displaying the GUI on a WinXP machine using xming/ssh. However, when I click a menu and let the cursor hover over the menu jedit records it as I am pointing at the first or second item in the menu (i.e., click the Plugins menu, when the menu opens the Plugin Manager or Plugin Options are selected, depending on whether I clicked 'high' or 'low' on the menu). Moving the cursor down also moves the focus so that when I hover over Plugin Options the P-Z menu is selected.

It gets worse. If I move the main window (non maximized) jedit does not register that so if I move the window 100 px to the left I have to click 100 px to the right of where I want to click to open a menu.

This problem only applies to elements in the menus. Buttons, the main text area and the actual menu label (File, Edit, Search etc) work as expected (that is, mouse actions are not displaced or shifted). Roughly, in the intial view before maximixzing or moving the window, the displacement in height correspond to the height of a menu bar in Windows or Mac OS X (which I also run this instance of jedit from).

Jedit 4.3pre17

$ java -version
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)

Removing the ~/.jedit/properties file didn't make a difference.

Submitted david-bo - 2009-09-24 - 13:55:32z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2009-09-24 - 22:18:28z
I have seen this in the past too. I assumed it was a buggy X client.
Perhaps you can doublecheck that you have the latest version of xming?
2009-09-25 - 07:56:05z
It is the most recent version, However, noticed another peculiarity when testing this issue. Have two WinXP machines, A and B. It is on A I have used ssh/xming/jedit and have had this problem.

After installing xming on B I tried launching jedit on B. It worked but jedit popped up on A's screen!?!? Other programs, simple like xeyes as well as more complex like Firefox and Open Office, are, when launched from B, displayed on B's screen.

Is jedit doing something funky? Or is it the JRE? Something else?
2009-09-25 - 08:40:49z
The version you installed - 4.3pre17 - had a bug related to multiple screens, which is fixed on the main trunk. If you like, you can download an up-to-date version from the jEdit daily-builds (link below). However, this bug is not related at all to the menu issue.