PreviousNextTracker indexSee it online !

(117/231) 3311234 - encoding of macros is not specified

Beanshell macros are loaded with the default encoding.
This results in an error message when I run Macros/Insert Buffer Properties
since I have set UTF-8 as default encoding and Insert_Buffer_Properties.bsh is in ISO-8859-1 and contains an accented char (รถ).

I can't change the encoding of the file or it will result in a warning with other default encodings.
Specifying an encoding when calling jEdit.openTemporary() in Beanshell._runScript() seems the best option.
Then, what encoding would you like ?

Submitted kerik-sf - 2011-06-03 - 19:07:26z Assigned nobody
Priority 5 Category macros
Status Open Group None
Resolution None Visibility No


2012-03-11 - 18:27:31z
Only macros/Insert_Buffer_Properties.bsh poses problem.
Following a recent discussion on the mailing list ( we should change the encoding of the macro and specify UTF-8 in Beanshell._runScript.
I'll create a patch.
2013-02-20 - 18:32:36z
the macro has been changed to utf-8 meanwhile.
I've added an explicit utf-8 encoding in r22807.
I'm still not happy about this source of non-portability in jEdit.


2013-02-20 - 18:44:07z

diff against r22807 to force loading macros as UTF-8