PreviousNextTracker indexSee it online !

(119/231) 3348248 - Search And Replace Window GUI doesn't properly update

The search and replace window doesn't properly update the GUI between uses (this is the only window that does this). For example, if the last time I used it I chose "Search in Current Buffer" (and then closed it) but I've now selected some lines of text and hit ctrl-F, when it opens up it shows the "Current Buffer" radio button selected, but if I just mouseover the radio button, it unselects it (so that none are selected). Then I mouseover the Selection radio button and that one suddenly shows as turned on.

I also get text left in the text boxes of this window as well, but on entering the text box, they disappear.

Using Linux/openSUSE.

No other window in jEdit does this.

Submitted donrhummy - 2011-07-01 - 01:42:14z Assigned nobody
Priority 5 Category search and replace
Status Open Group None
Resolution None Visibility No


2011-07-01 - 04:52:07z
About the selection radio button: Which Look&Feel are you using? The L&F is usually configured using one of the following two options:
1. Global Options - Appearance - Swing look & feel
2. The LookAndFeel plugin
Have you tried with another L&F?

About the text left in the text boxes - does it appear selected? If you have something selected in the buffer when you hit Ctrl+F, then this selection should appear by default in the "Search for:" box.
2011-07-01 - 05:13:50z
The look&feel is "Metal." It's always been that and 3-4 versions ago, this didn't happen. I have not tried with a different L&F but I will.

The text does not appear selected. And actually the text usuallt appears to be partially wiped at the beginning of it (usually missing part of a letter or two).
2011-07-01 - 06:00:05z
In that case, I believe it's not an L&F issue but a Java or OS (window manager?) issue.
Can you attach a screenshot, and add the beginning of the activity log file (~/.jedit/activity.log) where the some environment settings (e.g. java version) are reported?
2011-07-01 - 19:06:35z
You can see in the attached file that I've moused over "Current Buffer" but not yet moused over "Selection," so it now shows current buffer as selected but has not shown the unselection of "Selection." Also, notice the close button appears as though it's in a mousedown, but when I mouse over it, it goes to normal.
2011-07-23 - 12:53:02z
Can you also add the beginning of the activity log?


2011-07-01 - 19:05:13z

Search And Replace