PreviousNextTracker indexSee it online !

(159/231) 3539186 - dynamic Shortcuts (Console, PV) don't work at startup

I'm not sure whether this is a bug in jEdit or Console, so starting with jEdit.

I have some shortcuts assigned to Console Commando scripts. Just for the sake of illustration, I assigned "CTRL-m a" to run the "ant" script.

When I start jEdit, that shortcut does not work. Other shortcuts work fine (e.g., in my configuration, hitting "CTRL-m s" brings ProjectViewer's search dialog just fine).

If I go into the jEdit Options dialog and just click OK, not changing anything, then the Command shortcut starts working.

I wonder if there's a race during initialization; since Commandos are a dynamic list, I wonder if jEdit is setting up the shortcuts before Console has had a chance to initialize. Or something.

Submitted vanza - 2012-06-30 - 19:24:19z Assigned nobody
Priority 5 Category keyboard / shortcuts
Status Open Group None
Resolution None Visibility No


2012-08-03 - 19:16:55z
Same is true for ProjectViewer project shortcuts.
Dynamic shortcuts only happen after the plugin is started and not when it is loaded.
2012-09-11 - 04:32:40z
I think it's a little bit more than that. Both plugins are started - the dockables are open, I can run commands in the console window. But the dynamic shortcuts still do not work.
2012-09-29 - 22:02:02z
I ran into this issue as well. A workaround is to put this into a startup script in your home directory:


When I did this, all my shortcuts worked right after startup.