PreviousNextTracker indexSee it online !

(219/231) 3615181 - doesn't find/use Java7 (OSX 10.9)

Mac OS X 10.9
java -version
java version "1.7.0_17"
Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
jEdit 5.1.0

Installed Plugins:
Common Controls
Mac OS X Support

How it happened:
I had another version of jEdit (I guess jEdit 4) and Java 6 before and my jEdit was working fine.

Then I installed Java 7 but when I tried to run the jEdit it brought up an alert saying it needs Java SE 6 to run!

I did some search in the net, and it seems that jEdit 4.5 (and I guess jEdit 5.1 too!) should not have any issue with Java 7, so I got rid of the old version, downloaded jEdit 5.1.0 and installed it. I expected that it should work and don't bring up that complain alert BUT it didn't work and brought up *To open "," you need a Java SE 6 runtime.* complain again, it offers to install Java 6 too and if I select *Not now* (because I need Java 7) it closes the application.

I still could run jEdit using this command, but I can't use Ctrl+C & Ctrl+V shortcuts for copy and paste!
java -jar /Applications/
the first time that I ran this command, it brought up plugin manager up and said some of plugins (including Mac OS X Support) needs to be updated, and so I updated them.

I don't think Activity log has any useful information in this case, because program is closed before it got started.

Submitted monolus - 2013-11-04 - 18:14:23z Assigned nobody
Priority 5 Category MacOSX specific
Status Open Group None
Resolution None Visibility No


2013-11-04 - 18:33:32z
Duplicate of 3563983
2013-11-04 - 19:44:02z
ok reopening the ticket.
3563983 describes what happens on OSX 10.8
this ticket describes what happens with OSX 10.9.
When the Mac installer is replaced with a newer one, both issues will be resolved at the same time.

2013-11-20 - 19:37:57z
Looks like the app starter needs to use this to get the JAVA_HOME value:
/usr/libexec/java_home -v 1.7