PreviousNextTracker indexSee it online !

(2/22) 2926116 - Patch to add pluginset command-line option

This patch allows users to choose which plugins jEdit loads at startup by specifying a PluginSet .xml file through the -pluginset command-line switch.

This is my first patch submission, so it may need a little more testing before being committed.

Submitted kog13 - 2010-01-05 - 09:45:58z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution Remind Visibility No


2010-01-05 - 09:46:55z
This patch should be applied to
2010-01-07 - 02:17:33z
I can't seem to get it to work for me.

[ezust@cerberus] /home/ezust/.jedit> jedit -pluginset=pluginset.xml
6:14:26 PM [main] [error] PluginJAR: Cannot load plugin /home/ezust/workspace/jedit/trunk/build/jars/JCalculator.jar
6:14:26 PM [main] [error] PluginJAR: error in opening zip file
6:14:26 PM [main] [error] PluginJAR: at Method)
6:14:26 PM [main] [error] PluginJAR: at<init>(
6:14:26 PM [main] [error] PluginJAR: at<init>(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.PluginJAR.getZipFile(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.PluginJAR.generateCache(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.PluginJAR.init(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.jEdit.addPluginJAR(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.jEdit.addPluginJARsFromDirectory(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.jEdit.initPlugins(
6:14:26 PM [main] [error] PluginJAR: at org.gjt.sp.jedit.jEdit.main(
6:14:26 PM [main] [error] ErrorListDialog$ErrorEntry: /home/ezust/workspace/jedit/trunk/build/jars/JCalculator.jar:
6:14:26 PM [main] [error] ErrorListDialog$ErrorEntry: Cannot load: error in opening zip file
6:14:26 PM [main] [error] ErrorListDialog$ErrorEntry: The most likely reason is that the JAR file is corrupt; try
6:14:26 PM [main] [error] ErrorListDialog$ErrorEntry: reinstalling it. See Utilities->Troubleshooting->Activity Log
6:14:26 PM [main] [error] ErrorListDialog$ErrorEntry: for a full stack trace.
6:14:26 PM [main] [error] jEdit: Failed to generate cache while loading plugin JCalculator.jar
6:14:26 PM [main] [error] main: Exception in thread "main"
6:14:26 PM [main] [error] main: java.lang.NullPointerException
6:14:26 PM [main] [error] main: at org.gjt.sp.jedit.jEdit.addPluginJARsFromDirectory(
6:14:26 PM [main] [error] main: at org.gjt.sp.jedit.jEdit.initPlugins(
6:14:26 PM [main] [error] main: at org.gjt.sp.jedit.jEdit.main(
2010-01-07 - 16:56:48z
What PluginSets are you using? It seems to work fine with mine (I uploaded the two that I tested with).
2010-01-08 - 16:06:52z
Can you try it now? I know I fixed at least one bug, but I don't know if it's the one you were having. Your PluginSets now work on my machine, though, so hopefully it solved the problem.
2010-11-25 - 17:57:48z
I am sorry, this totally fell off my stack. I just tried to apply it and now 1 of the hunks fails against jedit trunk.
If you revisit and resubmit, I will make a point of testing it faster this time. sorry about that!
[and there is still a chance of getting it into 4.4 if it works]


2010-01-07 - 16:53:28z

PluginSet test file.

2010-01-07 - 16:54:52z

PluginSet test file.

2010-01-07 - 17:11:18z

alan's minimal pluginset.xml

2010-01-07 - 17:11:49z

alan's full pluginset.xml

2010-01-08 - 16:05:49z

Fixed a bug that caused errors when a plugin defined in a PluginSet could not be found.