PreviousNextTracker indexSee it online !

(41/314) 1611410 - FTP plugin - save leads to OS freeze on XP

When I try to save a document in Jedit from my (office) XP computer via the FTP-plugin I get the following results:
Jedit claims for several minutes (estimated) I/O activity. Then the I/O job is aborted.
Afterwards my whole computer is practically unusable. All actions take a huge amount of time. No network connection any more (e.g. impossible to browse the internet or to connect a server via ssh). The computer cannot shut-down any more - the only way to shut down is via cold-shut-down. :-(

This is reproducable behaviour.
I attach the activity-log to this bug-report.

I use the windows install of Jedit 4.3pre8 together with
Sun JavaRE 5.0 update 9 on Windows XP.

The FTP-server is an 3 year old Solaris-server. Half a year ago I used to work successfully with an older version Jedit and an older version of the FTP-plugin from a different Windows2000 computer (from a different location).

Unfortunately I am not able to interpret the activity log - Could somebody explain shortly what the problem might be?

p.s. I am only a Jedit user (not a developer of any kind), please excuse if my descriptions are insufficient or technically not correct.
Please let me know if you need further information.
Thanks for providing Jedit and the FTP plugin

Submitted goebbe - 2006-12-08 - 10:25:05z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2006-12-08 - 10:33:09z
Logged In: YES
Originator: YES

Just to complete my description:
I can successfully connect to the server.
I can browse the file structure on the server.
I can open files from the server (via the FTP-plugin).
So the problem appears only when saving via the FTP-plugin.

When I use the free FTP-client FileZilla I can save files (upload) without problems on the server.
2006-12-08 - 15:42:15z
Logged In: YES
Originator: YES

The problem is also present when trying to save via FTP-plugin 0.8 from Jedit4.3pre8 with Sun Java RE 5.0 update10 on WinXP and
the problem is also present when trying to save via FTP-plugin 0.73 from Jedit4.2final with Sun Java RE 5.0 update10 on WinXP.

However I succeeded in saving Files via the latest FTP-plugin from Jedit4.3pre8 and Sun Java RE 5.0 update8 on Ubuntu Linux.
The first time I tried to save via FTP-plugin on Ubuntu I got an error message that saving was not successful, however network was still up and now it is working like charm and saving the documents in a fraction of seconds - this happened with Jedit4.3pre7 AND Jedit4.3pre8!

I am going to attach the activity log for "the first time refusing/now it works"-experience under Ubuntu - since I guess that the "first time refusing" is related to the bug report. Is there something special going on at the first connection via FTP-plugin? For some reason the problems are sorted out after a first refused attempt under Linux but they lead to a broken system and the inability to shutdown under WinXP.

2006-12-08 - 15:43:46z
Logged In: YES
Originator: YES

File Added: activity_log_first_time_refusing_linux


2006-12-08 - 10:25:05z

Activity log

2006-12-08 - 15:43:45z

activity log for my first time refused, now it works experience under Ubuntu