PreviousNextTracker indexSee it online !

(105/314) 2807955 - EditorScheme 1.2.0 fails on JDK 1.5.0_16

- Windows XP SP2
- Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
- jEdit 4.3pre16
- EditorScheme 1.2.0

EditorScheme 1.2.0 fails on attempt to open plugin UI from Plugins menu:

C:\Program Files\jEdit\jars\EditorScheme.jar:
Cannot start: java.lang.UnsupportedClassVersionError: Bad version number in .class file
Try updating to a newer version of the plugin

The last line of the error is quite ironic, since I just *did* update to the newer version :)

I suspect it's barfing on my JDK version, even tho the plugin docs claim it supports 1.5.x

Submitted phipster - 2009-06-17 - 20:44:43z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2009-06-19 - 03:09:28z
Update: the plugin loads and runs OK on my home PC which has JDK 1.6.0_13-b03 installed.
2009-06-19 - 03:34:04z
Oops. I must have built it with JDK 6, sorry about that.

I'll re-release it and make sure to set the java version to 5.

2009-06-19 - 03:46:27z
I've re packaged and released it built with java 5.

It will take a while for all the mirrors to get updated, but you can download it manually here: