PreviousNextTracker indexSee it online !

(124/314) 2988179 - BufferTabs: Impossible to switch from a buffer to another

jEdit 4.3.1
Java 1.6.0_12
Windows XP Professionnal
After a while (I don't know how long yet !), it is impossible to switch from a buffer to another. A Buffer Tabs plugin reset is then necessary (Untick and "re-tick" the option in the menu Plugins\BufferTabs\Buffer Tabs)

Submitted chrdo - 2010-04-16 - 09:39:32z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2010-04-22 - 18:21:51z
Changing the subject and type as this is a plugin bug, not a core bug.
If switching buffers is also impossible using the built-in buffer switcher, that's something else, but it's not what the details say.
2010-09-10 - 08:08:20z
Same problem now I am using jEdit 4.3.2 server mode with Java 1.6.0_18 under Ubuntu 10.04
2011-06-01 - 22:38:23z
I have found that when I use the Tags plug-in, I can no longer switch buffers. Clicking on a tab does nothing. I have verified that any time I "follow" a tag I loose the buffer switching ability. Restarting Jedit clears it, but that's not a very desirable solution.
2011-06-02 - 06:20:29z
I'm not sure that the Tags plugin is still supported. I have written CtagsInterface, which for most cases can be a suitable replacement. Would you like to try CtagsInterface instead? CtagsInterface can also keep the tag database up-to-date when you modify files via jEdit.
2011-06-02 - 14:13:15z
Note that this "BufferTabs plugin seems to hang from time to time" problem was around for many revisions, but seems to have disappeared somewhere along the way. I'm not positive what rev it was, I'm using the daily builds. I have switched to the new Lucene based tags, daily build of 4.5pre1, daily build of BufferTabs, etc, and have not seen the problem since leaving 4.4. Just a data point, in case it helps.
2011-06-02 - 14:28:08z
You know, the ctagsinterface looks nice, but I have not had a lot of success getting it to work the way I want... the tags interface was pretty simple. build a tags file from the command line, I generally use a file with a list of the files I want indexed, then just jump to a tag and pop back. That's pretty much all I wanted. With ctagsinterface I've tried to "set a tag file", but even after doing so, I am generally given a "tag not found" dialog. There is a jump to tag but no pop stack? Anyway.. I'd love more information on making that work. The help file seems a little thin.

Regarding the daily builds.. I'm not as up-to-speed on that as I would like to be, but that might be a good solution.
2011-06-02 - 14:30:58z
I tried the daily build of 4.5, and the daily build of buffertabs.. when I did a jump to tag using the tags plugin, I get the same issue. I guess I'll need to quit using the tags plugin and figure out how to best use ctagsinterface..
2011-08-23 - 09:58:08z
Toggling the Plugins\BufferTabs tick is a lighter workaround than restarting Jedit....
Tags \ Pop position is indeed really a missing feature in ctagsinterface plugin