PreviousNextTracker indexSee it online !

(205/314) 3560671 - FastOpen + MyDoggy: issues with dockable actions.

FastOpen behaves differently between my two environments. On my Window box, if I have nothing selected and hit my shortcut for FastOpen, it opens the dialog and gives focus to the filename box, just like I would expect. On my Linux box, if nothing is selected, nothing happens. No dialog pops up. Both machines work the same and correctly if a word is selected in the buffer, the dialog pops up if the name is ambiguous with the selected word in the filename, or it directly opens the file if the selected word is an unambiguous filename.

Both boxes are using latest FastOpen from plugin manager.

Here's the not working Linux config:
jEdit 5.0pre2 daily from 02-July-12
7:02:40 AM [main] [message] Log: java.version=1.7.0_05
7:02:40 AM [main] [message] Log: java.vm.version=23.1-b03
7:02:40 AM [main] [message] Log: HotSpot(TM) 64-Bit Server VM
7:02:40 AM [main] [message] Log: java.runtime.version=1.7.0_05-b06
7:02:40 AM [main] [message] Log: SE Runtime Environment
7:02:40 AM [main] [message] Log: java.vendor=Oracle Corporation
7:02:40 AM [main] [message] Log: java.compiler=null
7:02:40 AM [main] [message] Log:
7:02:40 AM [main] [message] Log: os.version=2.6.18-238.el5
7:02:40 AM [main] [message] Log: os.arch=amd64
7:02:41 AM [AWT-EventQueue-0] [debug] EditBus: PluginUpdate[what=LOADED,exit=false,version=2.5,source=/ln/home/snarum/.jedit/jars/FastOpen.jar,class=com.patelsoft.fastopen.FastOpenPlugin]

And here is the working Windows version:
jEdit 5.0pre1 downloaded 10-July-12 (I don't think it was a daily)
8:03:12 AM [main] [message] Log: java.version=1.7.0_05
8:03:12 AM [main] [message] Log: java.vm.version=23.1-b03
8:03:12 AM [main] [message] Log: HotSpot(TM) Client VM
8:03:12 AM [main] [message] Log: java.runtime.version=1.7.0_05-b06
8:03:12 AM [main] [message] Log: SE Runtime Environment
8:03:12 AM [main] [message] Log: java.vendor=Oracle Corporation
8:03:12 AM [main] [message] Log: java.compiler=null
8:03:12 AM [main] [message] Log: 7
8:03:12 AM [main] [message] Log: os.version=6.1
8:03:12 AM [main] [message] Log: os.arch=x86
8:03:13 AM [AWT-EventQueue-0] [debug] EditBus: PluginUpdate[what=LOADED,exit=false,version=2.5,source=C:\Users\snarum\AppData\Roaming\jEdit\jars\FastOpen.jar,class=com.patelsoft.fastopen.FastOpenPlugin]

Submitted snarum-micron - 2012-08-22 - 14:16:10z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2012-08-22 - 14:29:40z
Interestingly, after filing the report, the Windows box is now doing the same as the Linux box... nothing. This definitely worked a moment ago, even after I sent this report, but now is not.
2012-08-22 - 15:14:47z
Is your shortcut for fastopen bound to the show-dockable action or the "show fast open dialog"?

2012-08-22 - 15:21:01z
Whatever action it is currently bound to, try binding your shortcut to the other (dockable vs dialog) and see if you have the same problem.
2012-08-22 - 17:46:42z
On both machines, by shortcut was pointing to 'Fast Open'. I changed it to "Show Fast Open Dialog" and it now works repeatedly. I see four total things when I filter on 'fast' in the shortcut options dialog:
Fast Open (<== bug reported on this one)
Fast Open (new floating instance)
Fast Open (toggle)
Show Fast Open Dialog (<== seems to work with this one)

Perhaps it is just me that is confused as to the need for four, and how they differ.
2012-08-22 - 18:05:47z
I can not reproduce your issue on linux or windows with java 1.6.
I normally use the "Fast Open" action that brings a dockable (not a dialog).
Which means FastOpen can be docked or floating, just like any other dockable.
Anyway, the first 3 are for controlling the dockable version of FastOpen, and the last one is for opening a dialog, which is not dockable. Which one you use depends on your preference. I like the dockable version.
Jiger likes the dialog.

2012-08-22 - 18:25:20z
OK, some more data is probably appropriate then. My original problem was using the dockable version with the dockable floating. I did not try it docked. I just tried it now, by switching my shortcut back to 'Fast Open', and selecting the FastOpen to be docked Top. Now when I hit my keystroke, the Fast Open dialog pops up ever time. Note, I did not say that the dockable opens, I said the dialog pops up, floating. The usual buttons across the top when you have a floating dockable are not present. Dragging it into a docking area does not work. Etc.

That brings up one more point, I am using MyDoggy for docking. I just turned it off, with no change in behavior.

Nothing changed this until I reloaded FastOpen using Activator plugin. Once I did, the dockable immediately appeared docked at the top like I told it to. It seems to work this way (other than being docked, which I don't like.) I then put it back to floating and the problem immediately reappeared (no reload of fast open required.)
2012-08-22 - 18:47:05z
I can't reproduce any of your problems if I am not using MyDoggy. Are you sure you see no difference?
I am going to change the subject to indicate this is a FastOpen+MyDoggy issue.
Did you really restart jEdit after selecting classic dockables to verify that you really are not using MyDoggy and *really* have the same problems?

I just tried opening the FastOpen Dockable in mydoggy, it was initially floating. Then I tried to dock it to the top.
Then I invoked the FastOpen action again and got this stacktrace below.

I don't think this is the same bug you had, but it does demonstrate that all is not right with MyDoggy + FastOpen.

java.lang.RuntimeException: java.lang.NullPointerException
at org.noos.xing.mydoggy.plaf.persistence.xml.XMLPersistenceDelegate.saveInternal(
at org.noos.xing.mydoggy.plaf.MyDoggyToolWindowBar.setToolsVisible(
at myDoggy.MyDoggyWindowManager.closeCurrentArea(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.gjt.sp.jedit.bsh.Reflect.invokeMethod(
at org.gjt.sp.jedit.bsh.Reflect.invokeObjectMethod(
at org.gjt.sp.jedit.bsh.Name.invokeMethod(
at org.gjt.sp.jedit.bsh.BSHMethodInvocation.eval(
at org.gjt.sp.jedit.bsh.BSHPrimaryExpression.eval(
at org.gjt.sp.jedit.bsh.BSHPrimaryExpression.eval(
at org.gjt.sp.jedit.bsh.BSHBlock.evalBlock(
at org.gjt.sp.jedit.bsh.BSHBlock.eval(
at org.gjt.sp.jedit.bsh.BshMethod.invokeImpl(
at org.gjt.sp.jedit.bsh.BshMethod.invoke(
at org.gjt.sp.jedit.bsh.BshMethod.invoke(
at org.gjt.sp.jedit.BeanShellFacade.runCachedBlock(
at org.gjt.sp.jedit.BeanShell.runCachedBlock(
at org.gjt.sp.jedit.BeanShellAction.invoke(
at org.gjt.sp.jedit.gui.InputHandler.invokeAction(
at org.gjt.sp.jedit.gui.InputHandler.invokeAction(
at org.gjt.sp.jedit.gui.DefaultInputHandler.handleKey(
at org.gjt.sp.jedit.input.AbstractInputHandler.processKeyEventKeyStrokeHandling(
at org.gjt.sp.jedit.gui.InputHandler.processKeyEvent(
at org.gjt.sp.jedit.textarea.TextArea.processKeyEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.KeyboardFocusManager.redispatchEvent(
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$000(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(
Caused by: java.lang.NullPointerException
at org.noos.xing.mydoggy.plaf.ui.cmp.FloatingFrame.getDockableCount(
at org.noos.xing.mydoggy.plaf.persistence.xml.XMLPersistenceDelegate.storeMultiSplitWindow(
at org.noos.xing.mydoggy.plaf.persistence.xml.XMLPersistenceDelegate$ToolWindowManagerElementWriter.write(
at org.noos.xing.mydoggy.plaf.persistence.xml.XMLPersistenceDelegate$ToolWindowManagerElementWriter.write(
at org.noos.xing.mydoggy.plaf.persistence.xml.XMLPersistenceDelegate.saveInternal(
... 59 more
2012-08-22 - 18:55:27z
Another interesting problem with FastOpen+MyDoggy : if I have 2 views open, and I select "FastOpen", nothing happens from one of the Views. I can only open the dockable from one of the views. The Dialog action works fine though.

2012-08-22 - 19:19:46z
OK, when I reported before that I had disabled MyDoggy, I did so by changing the selection in the Options->Docking dialog to Original. I did not restart. I just restarted with the setting to Original, verified using Activator that MyDoggy is not loaded, and I cannot reproduce the issue.