PreviousNextTracker indexSee it online !

(268/314) 665309 - JCompiler not reporting errors after first compile

I'm using Jedit version 4.0.3, with the latest version
of Jcompiler, on a win98 system. When I set JCompiler's
options to use Modern (JDK 1.3 or higher), and compile
any file or package that contains an error, the first
time it works fine and reports these errors in the
console window and error list, etc. From then on, if I
compile anything with errors, the output in the console
window looks exactly as if it compiled with no errors -
it simply says "JCompiler done." When I check my
directories I can see that the compilation did not
occur (because of the errors). JCompiler will never
report another error until I quit Jedit and restart it.
The first compile will then work as normal, and then
all later ones again report no errors. I've tried many
different combinations of JCompiler options, but none
of them make the problem go away.

If I select "Old (pre 1.3 JDK)", it reports
deprication, but the compiler does consistantly report
errors. However, it is at least 10 times as slow as
normal. I can select "External", with the Compiler
binary as "javac", and it also works - faster than Old,
but not as fast as Modern. I assume the slowdown is
because a seperate JVM is being loaded to run the
compile process. But the ability to compile from the
editor without starting up another JVM is the primary
reason I started using Jedit! (This did work properly
in Jedit 1.3.x.)

Thanks in advance for your time -

Submitted koryheath - 2003-01-09 - 20:58:59z Assigned gerardsmyth
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2005-03-09 - 13:23:57z
Logged In: YES

Sorry for not responding.

Is this bug still valid? Do you still get that error?