PreviousNextTracker indexSee it online !

(24/33) 773622 - Not opening files from explorer


On my work machine (Win 2000 SP3), jEdit 4.1 won't
open files from Explorer, whether by the 'Open with jEdit'
option or by the main 'Open with' submenu. Whenever I
try to open a file, jEdit starts up but doesn't open the
file. It's just as if I'd started jEdit from its icon.

If I start jEdit (by any means) I can use the File->Open
menu option to open files without a problem.

The problem doesn't seem to the use of network drives,
or having spaces in the path: I've tried it with
D:\test.txt and the problem still occurs.

I believe that 4.0 had the same problem on this PC. My
Windows XP machine at home runs 4.0 without this bug.

JRE is build 1.4.2-b28. It used to happen with 1.3.? as
well, I think.


Submitted rob_alexander - 2003-07-18 - 13:05:16z Assigned nobody
Priority 5 Category None
Status Open Group None
Resolution None Visibility No


2003-07-29 - 09:38:45z
Logged In: YES

If I look in jelaunch.log:

C:\Program Files\Java\j2re1.4.2\bin\javaw.exe -mx32m -
jar "C:\Program Files\jEdit 4.1\jedit.jar"

I.e. the launcher never passes the name of the text file to

I've built myself a workaround using a batch file:

"C:\Program Files\Java\j2re1.4.2\bin\javaw.exe" -mx32m -
jar "C:\Program Files\jEdit 4.1\jedit.jar" "%1"

This works, it opens files from the explorer. But I don't know
how to make the "Open with Jedit" buttons call this, if indeed
it is possible. (I have to use Open With -> jedit instead, not a
problem really).

Also, it leaves a console window open until JEdit exits, which
is ugly. Possibly there is a way to close the console window
while keeping JEdit running.

2003-08-06 - 14:40:11z
Logged In: YES

When I try it as my normal account. It doesn't work either.
However, I can open files this way when I am running things
as the Administrator. Something in the jLauncher is using
something it shouldn't. Perhaps that is the reason the
server file is not opened.... hmm...

jEditLauncher logging finished by module Wed., Aug. 6, 2003
at 11:29:06PM
jEditLauncher logging starting by module Wed., Aug. 6, 2003
at 11:34:23PM
2003-08-06 23:34:24.87 Debug : [launcher] default code
page is 1252
2003-08-06 23:34:24.87 Debug : [launcher] searching for
server file
2003-08-06 23:34:24.87 Debug : [launcher] Server file not
2003-08-06 23:34:24.90 Debug : [launcher] System error
message: The system cannot find the path specified.
2003-08-06 23:34:24.90 Debug : [launcher] Could not find
server file.
2003-08-06 23:34:24.93 Debug : [launcher] Command line:
2003-08-06 23:34:24.93 Debug : [launcher] Working directory:
2003-08-06 23:34:24.98 Error : [launcher] Error calling
CreateProcess() in launch routine. Error code: 2 - The
system cannot find the file specified.

jEditLauncher logging finished by module Wed., Aug. 6, 2003
at 11:34:29PM
2003-08-17 - 15:36:39z
Logged In: YES

So I noticed as well that there is no server file name in
the log. But when I run it as Administrator low and behold
it works and there is a server file name in the log:
C:\Documents and Settings\Administrator\.jedit\server ...
So something about not being Administrator is keeping the
file name from being loaded properly.

The log is written to by a member of the ServerConnection
class. The value of the 'server file' is only written to
when it is constructed and is passed in from a
RegistryParser in the GetServerFilePath() method. That
value is determined in this class and this is where we
should look.

In the RegistryParser the 'server file' is determined the
registry. And everything is done in the constructor here.
After that its only a container class of strings.

If LoadString failed, then RegOpenKeyEx would succeed but do
the wrong thing and then InitCmdLine and InitWorkingDir will
fail with out any logging until it logs that it can't open
server file. I can put a few logging lines in to find the
problem. What compiler can I download for this?
2003-08-19 - 13:22:31z
Logged In: YES

>I can put a few logging lines in to find the
>problem. What compiler can I download for this?

The launcher appears to have workspace and project files for
Visual C++ 6. I only have VC 7 here, which won't open them
(7 offers to convert them to the new format, but fails with an
error along the lines of 'project file is corrupt').

I have VC 7.1 at home, will try that when I get a chance.

2003-11-14 - 03:20:07z
Logged In: YES

This may be the same problem as "[ 632346 ] problem with
windows install"
Have you moved your desktop location?
2003-11-14 - 09:34:29z
Logged In: YES

I'm haven't used Jedit for a while now, indeed I don't
really use Windows much right now, but I tried this on a
colleague's machine and his desktop _is_ in the place that
Jedit is looking for it. There is, however, no .jedit
directory there.