PreviousNextTracker indexSee it online !

(58/231) 1964210 - Extra Word Characters ignored in LaTeX mode

From around 4.3 Pre 14, it seems that "Extra Word Characters" are ignored in LaTeX mode. I have these set for _$%@ in all modes.

Suppose the text area contains "\section{Some Heading}". Double-clicking on "Some" selects "section{Some", while double-clicking on "Heading" selects "Heading}". This used work in the expected way in earlier versions (i.e. only "Some" or "Heading" would be selected because {} weren't extra word characters).

This problem does not arise in plain text mode or HTML mode, so it may be LaTeX-specific. It may affect other modes I haven't tried.

Submitted kjt - 2008-05-14 - 22:41:51z Assigned nobody
Priority 5 Category text area and syntax packages
Status Open Group minor bug
Resolution None Visibility No


2008-05-15 - 17:58:36z
Logged In: YES
Originator: NO

In the Latex mode file "noWordSep" is set to "@_-:*{}[]<>". Apparently the matching setting of Global Options pane is merged with the mode file definition.

This behavior is standing in contrast to the documentation: "Changing options from this option pane ... override those set in mode files." But I don't know witch way they should work...

2008-05-15 - 18:32:26z
Logged In: YES
Originator: YES

You're right - I'd missed this setting, believing that the global values would prevail. But I think I've only just seen this behaviour, i.e. I don't recall it being like this previous version. Still, you've pointed out how I can override it.