PreviousNextTracker indexSee it online !

(166/231) 3563983 - DMG installer doesn't use Java 1.7 on Mac OS X

On Mac OS X I find that jEdit does not respect the "preferred" JVM setting. It seems to always use the Apple 1.6 JVM.

I am using jEdit v4.5.2, on Mac OS X v10.8.1.

To reproduce:
1) Use "Java Preferences" from "/Applications/Utilities", to change the the preference order for your installed JVMs. I have installed Oracle Java 7 and moved this to the top.
(see screenshot)

2) Verify this setting has taken hold by running "/usr/libexec/java_home" from a terminal window. Here's what I get:
jam:~ % /usr/libexec/java_home

3) Open jEdit, and go the "About jEdit" window to see which JVM is being used.
(see screenshot)

Other Java applications (such as NetBeans) respect this preferred JVM setting, as should jEdit.

Submitted Anonymous - 2012-09-01 - 16:06:36z Assigned nobody
Priority 5 Category MacOSX specific
Status Open Group None
Resolution None Visibility No


2013-09-18 - 02:38:35z
I just tried a newly installed OSX 10.8 without any JDK installed. Then I installed JDK 1.7 so it is the only version of Java that I have.

Then I tried to use the DMG installer for jEdit 5.1.

it complained that I didn't have JDK 1.6 installed and wouldn't let me install jEdit unless I first installed JDK 1.6.
So this is a related issue with the DMG installer, I think.
2013-09-18 - 18:44:46z
The screenshot with the Java prefs already indicates a major discontinuity: Java 6 was by Apple, but Java 7 is by Oracle. The key problem here is the executable wrapper to start the application inside the bundle. You have to choose the old regime or the new world order, by choosing the starter. I don't know a way to have both.

For Oracle Java 7 applications see

A fork of that project is here:


2012-09-01 - 16:06:37z

Java Preferences

2012-09-01 - 16:07:36z

jEdit About